Home > Old Post dari Unilanet, World Of ICT > BGP both ibgp and ebgp through Node and Sublocalnode INHERENT indonesia

BGP both ibgp and ebgp through Node and Sublocalnode INHERENT indonesia


The Border Gateway Protocol (BGP) is the protocol backing the core routing decisions on the Internet. It maintains a table of IP networks or ‘prefixes’ which designate network reachability  among autonomous systems (AS). It is described as a path vector protocol. BGP does not use traditional Interior Gateway Protocol (IGP) metrics, but makes routing decisions based on path, network policies and/or rulesets. For this reason, it is more appropriately termed a reachability protocol rather than routing protocol.

BGP was created to replace the Exterior Gateway Protocol (EGP) routing protocol to allow fully decentralized routing in order to allow the removal of the NSFNet Internet backbone network. This allowed the Internet to become a truly decentralized system. Since 1994, version four of the BGP has been in use on the Internet. All previous versions are now obsolete. The major enhancement in version 4 was support of Classless Inter-Domain Routing and use of route aggregation to decrease the size of routing tables. Since January 2006, version 4 is codified in RFC 4271, which went through more than 20 drafts based on the earlier RFC 1771 version 4. RFC 4271 version corrected a number of errors, clarified ambiguities and brought the RFC much closer to industry practices.When BGP is running inside an autonomous system (AS), it is referred to as Internal BGP (IBGP or Interior Border Gateway Protocol). When it runs between autonomous systems, it is called  External BGP (EBGP or Exterior Border Gateway Protocol). Routers on the boundary of one AS exchanging information with another AS are called border or edge routers. In the Cisco  operating system, IBGP routes have an administrative distance of 200, which is less preferred than either external BGP or any interior routing protocol. Other router implementations also prefer EBGP to IGPs, and IGPs to IBGP,

From Wikipedia, the free encyclopedia

 

University Of Lampung as one of maintainer Network INHERENT area Lampung had already implemented this BGP protocol through the neighbor border router and subnode as a partner.  We have two external border partner in difference province connected using metro-ethernet technology by PT Telekomunikasi Indonesia that is (UNSRI- Palembang) and (UNJA Jambi).

And also there 11 partner already joint to Area Lampung as a Localnode, several metode for routing protocol are used;

1.  Static Route (mainly use).

2.  Dynamic with ospf (failed run on metro-e, until now i don’t now why😦

3.  BGP (using ebgp).

 

FYI to whom it may concern, i will share for existing topology and logic connection on our CISCO 7606 series.

as you imagine that, all of partner using Fibre Optic as media network, here is the logic configuration

 

en#sh run

router ospf 100  !!! (this one for internal purpose to distribute using OSPF protocol to Internal Unila)
router-id 167.205.190.9
log-adjacency-changes
redistribute static
redistribute bgp 65009 subnets
network 167.205.143.0 0.0.0.255 area 0
!
router bgp 65009
no synchronization
bgp log-neighbor-changes
network 167.205.143.0 mask  255.255.255.240 !!! (Unila main Network)
network 167.205.143.16 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.24 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.32 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.40 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.48 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.56 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.64 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.72 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.80 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.143.88 mask 255.255.255.248 !!! ( Advertise Sublocalnode Partner)
network 167.205.180.24 mask 255.255.255.252 !!! ( Advertise Sublocalnode Partner)

redistribute connected !!! (To Share routing information)
redistribute ospf 100 route-map DENY_PRIVATE_ADDRESS (To share ospf protocol)
neighbor 167.205.182.118 remote-as 65009 !!! (EBGP for Sublocalnode UPBJJ Lampung)
neighbor 167.205.182.118 next-hop-self !!! (Distributed to UPBJJ)

neighbor 167.205.190.8 update-source Loopback0  !!! (Loopback IP)
neighbor 167.205.191.173 remote-as 65011  !!!(UNSRI- PALEMBANG)
neighbor 167.205.191.173 description UNSRI !!!(UNSRI- PALEMBANG)
neighbor 167.205.191.173 ebgp-multihop 255 !!!(UNSRI- PALEMBANG)
neighbor 167.205.191.173 soft-reconfiguration inbound !!!(UNSRI- PALEMBANG)
neighbor 167.205.191.178 remote-as 65012 !!!( UNJA-JAMBI)
neighbor 167.205.191.178 description JAMBI !!!( UNJA-JAMBI)
neighbor 167.205.191.178 ebgp-multihop 255 !!!( UNJA-JAMBI)
neighbor 167.205.191.178 soft-reconfiguration inbound !!!( UNJA-JAMBI)
maximum-paths 4
no auto-summary

ip classless
ip route 167.205.143.32 255.255.255.248 167.205.182.110
ip route 167.205.143.40 255.255.255.248 167.205.182.114
ip route 167.205.143.48 255.255.255.248 167.205.182.118
ip route 167.205.189.64 255.255.255.248 167.205.189.66
ip route 167.205.190.8 255.255.255.255 167.205.189.64
ip route 167.205.190.8 255.255.255.255 167.205.189.66
ip route 167.205.190.8 255.255.255.255 167.205.189.68
ip route 167.205.190.8 255.255.255.255 167.205.189.70
ip route 167.205.190.11 255.255.255.255 167.205.191.173
ip route 167.205.190.12 255.255.255.255 167.205.191.178

interface GigabitEthernet1/42
description to “SWITCH METRO ETHERNET  TELKOM”
no ip address
!
interface GigabitEthernet1/42.2510
description TEKNOKRAT
encapsulation dot1Q 2510
ip address 167.205.182.105 255.255.255.252
!
interface GigabitEthernet1/42.2511
description AMIK MASTER
encapsulation dot1Q 2511
ip address 167.205.182.97 255.255.255.252
!
interface GigabitEthernet1/42.2512
description UBL
encapsulation dot1Q 2512
ip address 167.205.182.109 255.255.255.252
!
interface GigabitEthernet1/42.2513
description STIBUN
encapsulation dot1Q 2513
ip address 167.205.182.101 255.255.255.252
!
interface GigabitEthernet1/42.2515
description STKIP-M-KOBUM
encapsulation dot1Q 2515
ip address 167.205.185.13 255.255.255.252
!
interface GigabitEthernet1/42.2516
description upbjj
encapsulation dot1Q 2516
ip address 167.205.182.117 255.255.255.252
!
interface GigabitEthernet1/42.2550
description TEKNOKRAT
encapsulation dot1Q 2550
ip address 167.205.185.1 255.255.255.252
!
interface GigabitEthernet1/42.2551
description STIE-SATUNUSA
encapsulation dot1Q 2551
ip address 167.205.185.5 255.255.255.252
!
interface GigabitEthernet1/42.2552
description STMIK-TUNASBANGSA
encapsulation dot1Q 2552
ip address 167.205.185.9 255.255.255.252
!
interface GigabitEthernet1/42.2553
description STIBA-YUNISDA
encapsulation dot1Q 2553
ip address 167.205.185.165 255.255.255.252
!
interface GigabitEthernet1/42.2572
description DARMAJAYA
encapsulation dot1Q 2572
ip address 167.205.182.113 255.255.255.252
!

  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: