Home > Old Post dari Unilanet > Quagga,FreeBSD dan ROUTER INHERENT

Quagga,FreeBSD dan ROUTER INHERENT


setelah 3 hari begadangan ngoprek RUTER 7606 dan Quagga
akhirnya Malem ini gue berhasil juga, jalanin Service Dynamic routing
di Mesin BSD biar gak susah susah tambahin static route ke INHERENT

Bagi Local node yang belum memiliki ASN,  bisa ikuti tips dan triks berikut.

Dengan konfirmasi terlebih dahulu ke Para Petinggi  Admin  INHERENT
service OSPF di router INHERENT UNILA  gue aktifin.seperti biasa enable dulu

IBRUNILA01>en
Password:
IBRUNILA01#

IBRUNILA01# configure terminal

router ospf 100
log-adjacency-changes
redistribute bgp 65009 subnets
network 167.205.143.0 0.0.0.255 area 0
!

Setting BGP di Router INHERENT

cuted….
router bgp 65009

redistribute ospf 100 route-map DENY_PRIVATE_ADDRESS
….

route-map DENY_PRIVATE_ADDRESS
match ip address 50

access-list 50 deny   10.0.0.0 0.255.255.255
access-list 50 deny   172.16.0.0 0.15.255.255
access-list 50 permit any

Yups Beres deh maenan dengan ROUTER 7606

Sekarang kita tinggal install quagga support zebra dan ospf
router-inherent# cd /usr/ports/net/quagga

┌────────────────────────────────────────────────────────
│                   Options for quagga 0.99.7_2
│ ┌───────────────────────────────────────────────────────
│ │  [X] ISISD            Enable experimental ISIS daemon
│ │  [X] PAM              PAM authentication for vtysh
│ │  [X] OSPF_NSSA        NSSA support (RFC1587)
│ │  [X] OSPF_OPAQUE_LSA  OSPF
│ │  [X] RTADV            IPv6 Router Advertisements
│ │  [ ] SNMP             SNMP support
│ │  [X] TCPSOCKETS       Use TCP/IP sockets
│ │  [X] TCPMD5           Use experimental MD5 patch for BGP
└───────────────────────────────────────────────────────
[  OK  ]       Cancel

router-inherent# make && make install clean

abis itu aktifin service quagga, dengan memasukkan statement berikut pada etc.rc.conf

router-inherent# vi /etc/rc.conf

quagga_enable=”YES”
quagga_flags=”-d”
quagga_daemons=”zebra ospfd”

and create file configurasi zebra.conf  dan ospfd.conf di direktori /usr/local/etc/quagga

contoh konfirasi zebra.conf yg dipake di mesin gue

Current configuration:
!
hostname Router
password KutuSapiKejepit
enable password KutuSapiKejepit
!
interface em0
ipv6 nd suppress-ra
!
interface lo0
!
interface pflog0
ipv6 nd suppress-ra
!
interface pfsync0
ipv6 nd suppress-ra
!
interface re0
ipv6 nd suppress-ra
!
interface rl0
ipv6 nd suppress-ra
!
ip forwarding
!
line vty
!
end

dan ini adalah  ospfd.conf yang ada dimesin gue

! Zebra configuration saved from vty
!   2007/07/19 19:04:49
!
hostname ospfd
password KutuKurap
enable password KutuKurap
log stdout
!
!
!
interface em0
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface re0
!
interface rl0
!
router ospf
network 167.205.143.0/24 area 0.0.0.0
network 222.124.196.96/27  area 0.0.0.1 -> area 1 untuk publish IP Public UNILA di Inherent
network 192.168.1.0/24 area 0.0.0.1    -> area 1 gue pake untuk semua server di Net1
!
line vty
!

OK beres Bos….

tinggal tes dengan masuk ke console ospf (quagga)

router-inherent# telnet localhost os
ospfd.conf       ospfd.conf.sav
router-inherent# telnet localhost ospfd
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.

Hello, this is Quagga (version 0.99.7).
Copyright 1996-2005 Kunihiro Ishiguro, et al.

User Access Verification

Password:
ospfd> en
Password:
ospfd#

ospfd# sh ip ospf border-routers
============ OSPF router routing table =============
R    167.205.190.9         [10] area: 0.0.0.0, ASBR
via 167.205.143.1, re0

ospfd#

Yups, berarti mesin BSD sudah bisa membaca tabel route dari ROUTER INHERENT

kalo gak percaya liat aja tabel routingnya, pasti dah banyak yang masuk

ospfd# sh ip ospf route
============ OSPF network routing table ============
N    167.205.143.0/28      [10] area: 0.0.0.0
directly attached to re0
N    192.168.1.0/24        [10] area: 0.0.0.1
directly attached to em0

============ OSPF router routing table =============
R    167.205.190.9         [10] area: 0.0.0.0, ASBR
via 167.205.143.1, re0

============ OSPF external routing table ===========
N E2 64.110.140.165/32     [10/1] tag: 65011
via 167.205.143.1, re0
N E2 64.110.141.48/28      [10/1] tag: 65008
via 167.205.143.1, re0
N E2 152.118.0.0/18        [10/1] tag: 65008
via 167.205.143.1, re0
N E2 152.118.64.0/18       [10/1] tag: 65008
via 167.205.143.1, re0
N E2 152.118.128.0/18      [10/1] tag: 65008
via 167.205.143.1, re0
N E2 152.118.192.0/18      [10/1] tag: 65008
via 167.205.143.1, re0
N E2 167.205.0.0/17        [10/1] tag: 65008
via 167.205.143.1, re0
N E2 167.205.62.239/32     [10/1] tag: 65008
via 167.205.143.1, re0
N E2 167.205.128.0/27      [10/1] tag: 65011
via 167.205.143.1, re0
N E2 167.205.128.240/28    [10/1] tag: 65011
via 167.205.143.1, re0
N E2 167.205.129.0/29      [10/1] tag: 65011
via 167.205.143.1, re0
N E2 167.205.130.0/27      [10/1] tag: 65008
via 167.205.143.1, re0
N E2 167.205.130.32/28     [10/1] tag: 65008
via 167.205.143.1, re0
N E2 167.205.130.64/29     [10/1] tag: 65008

Model  OSPF ini  seyogyanya juga akan gue gunakan untuk semua PTS
yang akan nyambung ke SIMPUL Unila

————————————————————–
Area 0 –> 167.205.143.0/24 (dipakai semua)
Area 1 –> PTS A  | IP publik INHERENT | IP publik PTS A (Internet)
Area 2 –> PTS B | IP publik INHERENT | IP publik PTS B (Internet)
Area 3 –> PTS C  | IP publik INHERENT | IP publik PTS C (Internet)
Area 4 –> PTS D| IP publik INHERENT | IP publik PTS D (Internet)
Area 5 –> PTS E | IP publik INHERENT | IP publik PTS E (Internet)
Area 6 –> PTS F| IP publik INHERENT | IP publik PTS F  (Internet)
——————————————————————-

  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: