Home > World Of ICT > Let’s make IPv6 Look More Complicated :-D

Let’s make IPv6 Look More Complicated :-D


Sore ini sembari menunggu hujan reda  sebelum menjemput istri tercinta pulang kerja, saya sempatkan menulis catatan singkat, lagi lagi topiknya adalah IPv6, bagi anda yang sudah bosen/jengah/jenuh membaca tulisan tentang IPv6 ini monggo silahkan klik tombol close pada browser sodara dan tidak usah diteruskan membacanya, namun bila anda merasa ingin tahu lebih dalam silahkan cermati tulisan saya.

Saya akan coba membuat IPv6 menjadi tampak seolah menjadi sesuatu yang rumit bin ribet, kenapa saya katakan demikian ??? ya iyalah tentunya IPv6 sungguh rumit bagi orang yang tidak mengerti, tapi bagi yang mengerti pasti menyadari akan simple nya mahluk bernama IPv6 ini.  So jadi anda mau pilih mana Ribet Ato Simple, jika ingin terlihat simple maka mulainya belajar dan googling dasar dasar-nya walaupun nanti ujung-ujungnya juga pasti gak simple😀 .

Hadooohhhh mulai dah tuh muter-muter gak karu-karuan, dari pada muter muterin kalimat gak jelas seperti acara JLC (Jakarta Lawyer Club) tadi malem membahas tentang Partai Demokrat, Wisma Atlet, Politik Tikus, blahhh..blahh…blahh.. mending stay tune disini untuk ngoprekin IPv6.

Dimulai pada studi kasus seperti berikut;

Saya dikasih Prefix IPv6 dari APNIC (Asia Pacific Network Information Center)  yakni 2001:df0:230::/48 , lalu ASN Public adalah 56237  , alokasi IPv4 dari Provider adalah 103.3.46.0/24, Kasus yang terjadi adalah si Provider saya ini Rada Bloon/Telmi/Oon/Lola jadi rupanya Network IPv6 tidak dapat melewatu Upstream mereka. Bos meminta Network Engineer untuk memecahkan permasalah ini.

Solusi:

Anggep saja saya sebagai Expert Network Engineer dimaksud, hal pertama kali yang saya katakan kepada BOS adalah Wani PIROOOOO……   Gampaaaaang Boss, tinggal dimainkan saja BARANG Tuh (Pinjem istilah Pak Batugana).

Pertama-tama siapakan peralatan tempur berupa device/server/PC yang akan dijadikan sebagai IPv6 Backbone, pilih alat-alat yang belum uzur jadi enak pada saat deployment kelak. Lalu cari partner Tunnel Broker yang mumpuni dan menyediakan layanan BGP Peer untuk advertise IPv6 kita, saya memilih http://he.net , layanan gratis dengan support ok dan mumpuni pula, untuk aktifasi layanan BGP baca tulisan saya berikut https://gigihfordanama.wordpress.com/2011/06/16/ipv6-create-bgp-tunnel-to-hurricane-electric-on-freebsd-with-quagga dibahas gamblang jika ingin mendaftarkan ASN publik yang kita miliki.

Singkat cerita dapatlah Parameter Alokasi BGP Peer yang akan digunakan ke HE.NET

IPv6 Tunnel Endpoints
Server IPv4 Address:216.218.221.2
Server IPv6 Address:2001:470:17:9::1/64
Client IPv4 Address:103.3.46.254
Client IPv6 Address:2001:470:17:9::2/64
Available DNS Resolvers
Anycasted IPv6 Caching Nameserver:2001:470:20::2
Anycasted IPv4 Caching Nameserver:74.82.42.42
BGP DetailsStatus: Available
Prefixes: 2001:0448::/32 (No LoA on file)
2001:0DF0:0230::/48 (LoA on file)
Your ASN:56237
Our ASN:6939
Peer Address:2001:470:17:9::1/64

Selanjutnya mau diapakan ini barang ???? ya tentunya diracik lah supaya jadinya NGERI NGERI SEDEP (Lagi lagi pinjam istilah pak Sutan Batugana😀 ) .

Skenario akan saya buat, BGP akan saya tanam dimesin Mikrotik lalu dari mesin Mikrotik di Announce Prefix IPv6 kita, dan buat mesin tersebut sebagai Gateway IPv6 Utama, Looks Simple bukan ?? , so Let’s do it….

Pastinya anda-anda Fans Mikrotik sudah familiar dengan barang bernama Winbox bukan ???  bukak tuh barang lalu remote server yang akan dijadikan BGP Peer baik V4 maupun V6.

Asumsi saya bahwa alokasi IPv4 Publik  sudah terpasang dengan baik misal alokasi IP yg saya gunakan adalah 103.3.46.254/24 , lalu jalankan perintah berikut (Didapat pada saat generate sample script versi mikrotik dari http://tunnelbroker.net )

/interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no local-address=103.3.46.254 mtu=1280 name=sit1 remote-address=216.218.221.2
/ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:17:9::1 scope=30 target-scope=10
/ipv6 address add address=2001:470:17:9::2/64 advertise=yes disabled=no eui-64=no interface=sit1

SET UP BGP Instance handle IPV4/IPV6

SET UP BGP PEERS

Parameter Advance aktifkan/Check List  ipv6

Set Network Prefix IPv6 Advertise

Assign IP Address di salah satu interface yang akan dijadikan Gateway IPV6 utama.

Muncul Peers sesuai parameter yang dimasukkan, tunggu sesaat lalu prefix akan bermunculan

 

 Finish lalu check apakah traffik ipv6 sudah bisa keluar

[gigih@ASBR-UNILA] > tool traceroute 2001:200:dff:fff1:216:3eff:feb1:44d7
 # ADDRESS                                 RT1   RT2   RT3   STATUS                                                                              
 1 2001:470:17:9::1                        65ms  65ms  65ms                                                                                      
 2 2001:470::b8:0:0:0:1                    66ms  74ms  76ms                                                                                      
 3 2001:470::16b:0:0:0:1                   231ms 225ms 225ms                                                                                     
 4 2001:470::18d:0:0:0:1                   231ms 231ms 240ms                                                                                     
 5 2001:470::31:0:0:0:2                    233ms 232ms 243ms                                                                                     
 6 2001:504::1:0:0:2914:1                  233ms 261ms 233ms                                                                                     
 7 2001:218::2000:0:0:0:aa                 355ms 336ms 338ms                                                                                     
 8 2001:218::2000:0:0:0:1b6                350ms 333ms 343ms                                                                                     
 9 2001:218::2000:0:0:0:1de                365ms 339ms 340ms                                                                                     
10 2001:218::6000:0:0:0:10e                357ms 338ms 341ms                                                                                     
11 2001:218:2000:5000::82                  393ms 339ms 342ms                                                                                     
12 2001:200::10:0:0:0:141                  358ms 338ms 341ms                                                                                     
13 2001:200::11:0:0:0:66                   357ms 340ms 341ms                                                                                     
14 2001:200::1c0a:218:8bff:fe43:d1d0       358ms 350ms 354ms                                                                                     

[gigih@ASBR-UNILA] > 

[gigih@ASBR-UNILA] > ping 2001:200:dff:fff1:216:3eff:feb1:44d7           
HOST                                     SIZE TTL TIME  STATUS                                                                                     
2001:200:dff:fff1:216:3eff:feb1:44d7       56  55 370ms echo reply                                                                                 
2001:200:dff:fff1:216:3eff:feb1:44d7       56  55 369ms echo reply                                                                                 
2001:200:dff:fff1:216:3eff:feb1:44d7       56  55 357ms echo reply                                                                                 
2001:200:dff:fff1:216:3eff:feb1:44d7       56  55 350ms echo reply                                                                                 
2001:200:dff:fff1:216:3eff:feb1:44d7       56  55 358ms echo reply                                                                                 
    sent=5 received=5 packet-loss=0% min-rtt=350ms avg-rtt=360ms max-rtt=370ms 

[gigih@ASBR-UNILA] >

Ya artinya sudah sukses jalankan BGP Peer di Mikrotik, lalu check apakah prefix kita sudah terbaca dan reachable dari luar ??, buka tools http://lg.as6453.net/bin/lg.cgi  lalu check barang tuh udah masuk apa Belum ??

Hasilnya adalah ;

BGP routing table entry for 2001:DF0:230::/48, version 1966443
Paths: (2 available, best #2, table Global-IPv6-Table)
  Advertised to update-groups:
     1          2        
  (8196) 6939 56237, (received-only)
    2A00:1798:0:1::1:21 from 2A00:1798:0:1::1:21 (212.6.200.27)
      Origin IGP, metric 0, localpref 0, valid, confed-external
      Community: 8196:700 8196:799
  6939 56237
    2001:7F8:54::10 from 2001:7F8:54::10 (216.218.252.175)
      Origin IGP, metric 2845, localpref 701, valid, external, best
      Community: 8975:711 8975:799 8975:13000 8975:15000
Traceroute Query

Router: gin-mtt-mcore3
Site: CA, Montreal - MTT, TATA COMM. INT. CENTER
Command: traceroute ipv6 www.unila.ac.id

Tracing the route to www.unila.ac.id (2001:DF0:230:2::5)

  1 if-xe-4-0-0.0.tcore2.NYY-NewYork.ipv6.as6453.net (2001:5A0:400:700::5) 8 msec
    if-xe-9-0-0.0.tcore2.NYY-NewYork.ipv6.as6453.net (2001:5A0:400:700::9) 8 msec
    if-xe-10-3-0.0.tcore2.NYY-NewYork.ipv6.as6453.net (2001:5A0:300:100::6) 8 msec
  2 if-ae11.2.tcore1.NYY-NewYork.ipv6.as6453.net (2001:5A0:400:700::2) 8 msec 8 msec 8 msec
  3 if-2-0-0.1577.core3.NTO-NewYork.ipv6.as6453.net (2001:5A0:A00::31) 8 msec 8 msec 8 msec
  4 gigabitethernet3-17.core1.nyc4.he.net (2001:470:0:1A3::1) 8 msec 8 msec 16 msec
  5 10gigabitethernet5-3.core1.lax1.he.net (2001:470:0:10E::1) 76 msec 72 msec 76 msec
  6 gige-g3-18.core1.hkg1.he.net (2001:470:0:16B::2) 236 msec 244 msec 236 msec
  7 gige-g0-1.tserv19.hkg1.ipv6.he.net (2001:470:0:B8::2) 236 msec 236 msec 400 msec
  8 donovanp-2-pt.tunnel.tserv19.hkg1.ipv6.he.net (2001:470:17:9::2) 420 msec 416 msec 428 msec
  9  *  *  *

Terakhir sambungkan Server Public agar terkoneksi IPv6 via Mikrotik Router tadi (Asumsi Interface NIC Server  yang diaktifkan adalah langsung berhadapan dengan Mikrotik V6 Router), karena Web Server Official saya berbasis FreeBSD dengan IP 103.3.46.1 maka saya aktifkan IPv6 statik pada mesin tersebut dan mengarahkan default route v6 nya ke server mikrotik, dengan cara sebagai berikut;

Tambahkan parameter berikut pada rc.conf

ipv6_enable="YES"
ipv6_ifconfig_igb0="2001:df0:230:2::5/64"
ipv6_defaultrouter="2001:df0:230:2::1"

Lalu reboot server dan test koneksinya.

groups# ifconfig
igb0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=13b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,TSO4>
        ether 78:e7:d1:5e:61:14
        inet 192.168.1.116 netmask 0xffffff00 broadcast 192.168.1.255
        inet 192.168.1.3 netmask 0xffffff00 broadcast 192.168.1.255
        inet6 2001:df0:230:2::5 prefixlen 64
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
igb1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=13b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,TSO4>
        ether 78:e7:d1:5e:61:15
        inet 172.16.1.2 netmask 0xffffff00 broadcast 172.16.1.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=3<RXCSUM,TXCSUM>
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet6 ::1 prefixlen 128
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
groups#
groups# traceroute6 www.kame.net
traceroute6 to orange.kame.net (2001:200:dff:fff1:216:3eff:feb1:44d7) from 2001:df0:230:2::5, 64 hops max, 12 byte packets
 1  2001:df0:230:2::1  12.823 ms  0.174 ms  0.160 ms
 2  donovanp-2.tunnel.tserv19.hkg1.ipv6.he.net  64.852 ms  64.290 ms  64.518 ms
 3  tserv19.hkg1.ipv6.he.net  65.231 ms  68.427 ms  75.780 ms
 4  gige-g3-7.core1.lax1.he.net  229.433 ms  225.253 ms  225.371 ms
 5  10gigabitethernet7-4.core1.fmt2.he.net  238.415 ms  231.391 ms  231.456 ms
 6  10gigabitethernet1-1.core1.sjc2.he.net  231.894 ms  239.045 ms  231.557 ms
 7  xe-0.equinix.snjsca04.us.bb.gin.ntt.net  233.673 ms  232.843 ms  302.326 ms
 8  as-1.r21.osakjp01.jp.bb.gin.ntt.net  402.883 ms  348.652 ms
    as-0.r21.tokyjp01.jp.bb.gin.ntt.net  333.948 ms
 9  ae-2.r22.osakjp01.jp.bb.gin.ntt.net  441.103 ms
    ae-2.r24.tokyjp01.jp.bb.gin.ntt.net  343.650 ms  343.349 ms
10  ae-5.r24.tokyjp01.jp.bb.gin.ntt.net  402.268 ms
    po-1.a15.tokyjp01.jp.ra.gin.ntt.net  344.527 ms  339.198 ms
11  ge-8-2.a15.tokyjp01.jp.ra.gin.ntt.net  345.809 ms
    po-1.a15.tokyjp01.jp.ra.gin.ntt.net  350.226 ms  357.113 ms
12  ve44.foundry6.otemachi.wide.ad.jp  338.583 ms  338.208 ms
    ge-8-2.a15.tokyjp01.jp.ra.gin.ntt.net  348.662 ms
13  ve44.foundry6.otemachi.wide.ad.jp  366.713 ms
    ve42.foundry4.nezu.wide.ad.jp  341.095 ms  340.593 ms
14  cloud-net1.wide.ad.jp  338.264 ms
    ve42.foundry4.nezu.wide.ad.jp  355.369 ms
    cloud-net1.wide.ad.jp  346.630 ms
15  2001:200:dff:fff1:216:3eff:feb1:44d7  367.010 ms  355.325 ms
    cloud-net1.wide.ad.jp  349.791 ms
groups#

Lihat bahwa  ip 2001:df0:230:2::1 sudah menjadi default route dari WebServer.

Terakhir tinggal berdoa semoga link koneksi bisa stabil.

Demikian, semoga ada manfaatnya…

  1. May 26, 2014 at 12:23 pm

    Hey there! Someone in my Myspace group shared this site with us
    so I came to give it a look. I’m definitely loving the
    information. I’m book-marking and will be tweeting this to my followers!
    Superb blog and amazing design and style.

  2. September 10, 2014 at 4:15 am

    izin nyimak om

    walaupun susah yaa buat newbie buat mengerti ,, belum nyampe situ om ilmu nya

  3. January 29, 2015 at 4:56 pm

    Mbacanya puyeng……. salut nice share…….

  4. January 15, 2016 at 4:28 am

    Saya sudah coba koneksi menggunakan link mor**** menggunakan IPV6 lancar jaya sama saja seperti set route BGP IPV6.

    http://www.jaringankantor.com

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: